记录oracle 9i for linux安装过程中几个错误

联系:手机(+86 13429648788) QQ(107644445)QQ咨询惜分飞

标题:记录oracle 9i for linux安装过程中几个错误

作者:惜分飞©版权所有[未经本人同意,不得以任何形式转载,否则有进一步追究法律责任的权利.]

最近因为一个测试环境需要oracle 9i,我在Oracle linux 4.8上安装,竟然遇到几个问题记录下:
1.运行runInstaller提示如下错误

[oracle@xifenfei Disk1]$ ./runInstaller 
[oracle@xifenfei Disk1]$ Initializing Java Virtual Machine from /tmp/OraInstall2012-03-04_09-32-16PM/jre/bin/java. Please wait...
Error occurred during initialization of VM
Unable to load native library: /tmp/OraInstall2012-03-04_09-32-16PM/jre/lib/i386/libjava.so: 
symbol __libc_wait, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

解决方法:打上p3006854_9204_LINUX.zip补丁

[root@xifenfei tmp]$ unzip p3006854_9204_LINUX.zip 
Archive:  p3006854_9204_LINUX.zip
   creating: 3006854/
  inflating: 3006854/rhel3_pre_install.sh  
  inflating: 3006854/README.txt 
[root@xifenfei 3006854]# cd 3006854
[root@xifenfei 3006854]# chmod +x rhel3_pre_install.sh 
[root@xifenfei 3006854]# ./rhel3_pre_install.sh 
Applying patch...
Ensuring permissions are correctly set...
Done.
Patch successfully applied

2.在Linking Oracle9i到63%时入到如下错误

解决办法:在/usr/bin目录下有gcc 和 gcc32两个文件,执行 mv gcc gcc296 和 mv gcc32 gcc,完成之后,retry安装界面

[root@xifenfei tmp]# cd /usr/bin
[root@xifenfei bin]# ls gcc*
gcc  gcc32  gcc4
[root@xifenfei bin]# mv gcc gcc296
[root@xifenfei bin]# mv gcc32 gcc

3.执行netca/dbca报如下错误

[oracle@xifenfei Disk1]$ dbca
/u01/oracle/jre/1.1.8/bin/../lib/i686/green_threads/libzip.so: symbol errno, 
version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)
Unable to initialize threads: cannot find class java/lang/Thread
Could not create Java VM
[oracle@xifenfei Disk1]$ netca
/u01/oracle/jre/1.1.8/bin/../lib/i686/native_threads/libzip.so: symbol errno, 
version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)
Unable to initialize threads: cannot find class java/lang/Thread
Could not create Java VM

解决办法:在环境变量中加上LD_ASSUME_KERNEL=2.4.1

vi .bash_profile --加上下面语句
export LD_ASSUME_KERNEL=2.4.1
source ~/.bash_profile
此条目发表在 Oracle安装升级 分类目录。将固定链接加入收藏夹。

记录oracle 9i for linux安装过程中几个错误》有 2 条评论

  1. xff 说:

    成熟的文档一大堆,原来公司有的,怎么会搞错!?

      [引用]  [回复]

  2. 惜分飞 说:

    建议安装以下版本或以上版本包

    compat-db-4.1.25-9 
    compat-gcc-32-3.2.3-47.3 
    compat-gcc-32-c++-3.2.3-47.3 
    compat-oracle-rhel4-1.0-3 
    compat-libcwait-2.0-1
    compat-libgcc-296-2.96-132.7.2 
    compat-libstdc++-296-2.96-132.7.2 
    compat-libstdc++-33-3.2.3-47.3 
    gcc-3.4.3-9.EL4 	
    gcc-c++-3.4.3-9.EL4 		
    gnome-libs-1.4.1.2.90-44 	
    gnome-libs-devel-1.4.1.2.90-44 	
    libaio-devel-0.3.102-1 	
    libaio-0.3.102-1 	
    make-3.80-5 	
    openmotif21-2.1.30-11 
    xorg-x11-deprecated-libs-devel-6.8.1-23.EL 
    xorg-x11-deprecated-libs-6.8.1-23.EL
    

      [引用]  [回复]

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注

您可以使用这些 HTML 标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>